Router Simulator for CCIE Lab

Dynagen/Dynamips(GNS3) 2008. 11. 2. 18:26
Router Simulator for CCIE Lab
 
Using a Router Simulator “DYNAMIPS” for the DOiT Workbook.
 
First of all, many thanks to Christophe Fillot and Greg Anuzelli for this software! It definitely opens up some new possibilities in the study process.
 
Please visit http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator and http://dyna-gen.soutrceforge.net for the installation instructions and documentation.
 
Since the router simulator does not simulate Catalyst switches, the catalyst sections of the DOiT workbook will not be a part of the scenarios. You will have to provide a work around. We will show how to use the dynamips simulator for the DOiT scenarios using examples of the setup and configuration of DOIT sample lab. The following diagram illustrates the cabling topology:
 

Note: The devices CAT1 and CAT2 are just the routes in the simulated topology.
 
 
 
 
Suggested approach with the DOiT labs under the simulated environment:
 
Look at the DOiT scenario diagrams and VLAN tables.
 
Make a list of all data links involved in the scenario.
Draw the new diagrams and modify the interface numbering (serial interfaces and fast Ethernet interfaces).
Create a network file for the scenario with the list of routers and Ethernet virtual switch. Configure access or trunk ports on the dynamips virtual Ethernet switch.
Replace ISL configuration with DOT1Q
Network files will be similar to the DOiT Sample scenario explained later in this document, as well as DOiT Scenario 1 network file attached in appendix B.
 
Modify the initial configuration scripts to reflect the changed interface numbers
 
Perform required configuration of the scenario on your routers.
 
Perform routing (IGP and BGP) configuration on the CAT1 and CAT2, as well as IOS features common to a cisco router and a cisco 3550 switch.
 
Compare results with the SHOWiT engine
 
Troubleshoot and verify with the TCL procedures supplied with the scenarios  in your portal.
 
 
 
The next two diagrams display modified IPv4 and IPv6 diagrams for the DOiT Sample Scenario (carefully look at the interfaces):

 
 
Step 1. Download and install dynamips and dynagen packages from their respective sites. You need a computer with a lot of memory (2 Gig). Choose your favorite operating system to host the simulator. We use Read Hat 9.0 linux in this example. Make sure you upgrade your Python to the latest version.
 
 
Step 2. Configure the network file. We suggest to uncompress IOS image. The following is an example of cabling setup for the DOiT Sample scenario nmc-sample.net:
 
[localhost]
workingdir = /home/study/
autostart = true
 
 
[[3640]]
idlepc = 0x606100e8
image = /home/study/c3640-jk9o3s-mz.124-5-uncompressed.bin
ram = 128
 
[[ROUTER FRS]]
console = 2007
model = 3640
s1/0 = R1 s1/0
s1/1 = R2 s1/0
s1/2 = R3 s1/0
s1/3 = R4 s1/0
F0/0 = SW1 7
[[ROUTER R1]]
console = 2001
model = 3640
F0/0 = SW1 1
#
[[ROUTER R2]]
console = 2002
model = 3640
s1/1 = R5 s1/0
#
[[ROUTER R3]]
console = 2003
model = 3640
F0/0 = SW1 3
#
[[ROUTER R4]]
console = 2004
model = 3640
#
[[ROUTER R5]]
console = 2005
model = 3640
#
[[ROUTER R6]]
console = 2006
model = 3640
F0/0 = SW1 6
#
[localhost:7201]
udp = 11000
#
[[3640]]
idlepc = 0x606100e8
image = /home/study/c3640-jk9o3s-mz.124-5-uncompressed.bin
ram = 128
#
[[ROUTER CAT1]]
console = 2008
model = 3640
ram = 128
F0/0 = SW1 8
#
[[ROUTER CAT2]]
console = 2009
model = 3640
ram = 128
F0/0 = SW1 9
#
[[ETHSW SW1]]
1 = dot1q 1
3 = access 360
6 = access 360
7 = access 17
8 = access 88
9 = access 360
 
 
 
Step 3. Run two dynamips processes:
 
nice dynamips –H 7200 &
nice dynamips –H 7201 &
 
 
Step 4. Start router instances and configure network topology used for the DOiT sample scenario:
 
 
./dynagen ../nmc-sample.net
 
Reading configuration file...
 
….
 
….
 
Your list of devices should look similar to a following:
 
=> list
Name       Type       State      Server          Console  
R1         3640       running    localhost:7200  2001     
R2         3640       running    localhost:7200  2002     
R3         3640       running    localhost:7200  2003     
R4         3640       running    localhost:7200  2004     
R5         3640       running    localhost:7200  2005     
R6         3640       running    localhost:7200  2006     
FRS        3640       running    localhost:7200  2007     
CAT1     3640       running    localhost:7201  2008     
CAT2     3640       running    localhost:7201  2009     
SW1      ETHSW      n/a        localhost:7201  n/a      
=>
 
Step 5. Open multiple telnet sessions to your unix machine using ports 2001 through 2009:
 
  
 
Configure your routers.
Router configuration scripts are attached in appendix A:
 
 
Step4. Verify connectivity:
 
R1#tclsh
R1(tcl)#tclsh
 
R1(tcl)#
R1(tcl)#
R1(tcl)#foreach address {
+>(tcl)#172.16.10.1
+>(tcl)#172.16.17.1
+>(tcl)#172.16.88.1
+>(tcl)#172.16.123.1
+>(tcl)#172.16.14.1
+>(tcl)#10.1.1.128
+>(tcl)#FEC0::BBBB:1
+>(tcl)#FEC0::1111:1
+>(tcl)#172.16.20.5
+>(tcl)#172.16.123.2
+>(tcl)#172.16.2.1
+>(tcl)#172.16.25.2
+>(tcl)#2.2.2.2
+>(tcl)#FEC0::BBBB:2
+>(tcl)#FEC0::AAAA:2
+>(tcl)#172.16.123.3
+>(tcl)#172.16.36.3
+>(tcl)#172.16.30.3
+>(tcl)#3.3.3.3
+>(tcl)#FEC0::BBBB:3
+>(tcl)#FEC0::D3D3:3
+>(tcl)#172.16.14.4
+>(tcl)#172.16.40.1
+>(tcl)#172.16.25.5
+>(tcl)#172.16.50.1
+>(tcl)#FEC0::AAAA:5
+>(tcl)#FEC0::5555:1
+>(tcl)#172.16.60.1
+>(tcl)#172.16.36.6
+>(tcl)#FEC0::6666:1
+>(tcl)#FEC0::D3D3:6
+>(tcl)#172.16.17.7
+>(tcl)#172.16.77.7
+>(tcl)#192.168.100.1
+>(tcl)#192.168.101.1
+>(tcl)#192.168.102.1
+>(tcl)#192.168.103.1
+>(tcl)#192.168.104.1
+>(tcl)#192.168.105.1
+>(tcl)#172.16.80.1
+>(tcl)#172.16.88.2
+>(tcl)#172.16.36.20
+>(tcl)#172.16.120.1
+>(tcl)#} {
+>(tcl)#ping $address
+>(tcl)#}
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.17.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.88.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 224/248/312 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.14.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 164/298/408 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.128, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::BBBB:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/4/8 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::1111:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/3/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/128/208 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 112/141/176 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/113/148 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.25.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/113/148 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/136/236 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::BBBB:2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/141/176 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::AAAA:2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/105/136 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/141/216 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.36.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/121/156 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 116/152/188 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/124/176 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::BBBB:3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/130/164 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::D3D3:3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/148/224 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.14.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 112/117/128 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.40.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/119/196 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.25.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/217/276 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.50.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 172/210/320 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::AAAA:5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 176/204/228 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::5555:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 176/196/232 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.60.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 164/191/236 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.36.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 140/183/236 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::6666:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 164/233/268 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0::D3D3:6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 104/196/240 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.17.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/61/88 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.77.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/84/132 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/81/104 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.101.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/65/100 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.102.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/49/76 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.103.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/75/116 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.104.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/53/76 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.105.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/75/116 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.80.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/78/96 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.88.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/41/92 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.36.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 168/204/220 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.120.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 212/307/364 ms
R1(tcl)#tclquit
 
 

 
 
Appendix A:
 
Router R1:
 
 
R1#sh run
Building configuration...
 
Current configuration : 4854 bytes
!
! Last configuration change at 00:22:32 UTC Fri Mar 1 2002
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip rcmd rsh-enable
ip rcmd remote-host R1 172.16.10.1 R1 enable
ip rcmd source-interface Loopback10
ip tcp synwait-time 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
!
!
class-map match-all UDP-STREAM
match access-group 101
match packet length min 1024 max 1024
!
!
policy-map UDP-TRAFFIC
class UDP-STREAM
  police cir 8000 bc 1500 be 1500
    conform-action transmit
    exceed-action drop
!
!
!
!
!
!
interface Loopback10
ip address 172.16.10.1 255.255.255.0
ip pim dense-mode
ip igmp join-group 230.30.30.30
!
interface Loopback100
no ip address
ipv6 address FEC0::1111:1/125
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.17
encapsulation dot1Q 17
ip address 172.16.17.1 255.255.255.0
no ip redirects
no snmp trap link-status
!
interface FastEthernet0/0.88
encapsulation dot1Q 88
ip address 172.16.88.1 255.255.255.0
no ip redirects
no snmp trap link-status
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 10.1.1.128 255.255.255.0
no ip redirects
no snmp trap link-status
service-policy input UDP-TRAFFIC
!
interface Serial1/0
ip address 172.16.14.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
cdp enable
frame-relay map ip 172.16.14.1 104
frame-relay map ip 172.16.14.4 104 broadcast
no frame-relay inverse-arp
!
interface Serial1/0.123 multipoint
ip address 172.16.123.1 255.255.255.0
ip pim dense-mode
ip ospf network broadcast
ipv6 address FEC0::BBBB:1/120
ipv6 address FE80::1111:1111 link-local
ipv6 ospf neighbor FE80::2222:2222
ipv6 ospf 1 area 0
frame-relay map ipv6 FE80::2222:2222 102 broadcast
frame-relay map ipv6 FE80::3333:3333 103 broadcast
frame-relay map ipv6 FEC0::BBBB:2 102
frame-relay map ipv6 FEC0::BBBB:3 103
frame-relay map ip 172.16.123.1 102
frame-relay map ip 172.16.123.2 102 broadcast
frame-relay map ip 172.16.123.3 103 broadcast
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router odr
network 172.16.0.0
!
router ospf 100
log-adjacency-changes
redistribute odr subnets
redistribute rip metric 20 subnets route-map RIP_TO_OSPF
network 172.16.123.0 0.0.0.255 area 0
!
router rip
version 2
redistribute odr metric 1
redistribute ospf 100 metric 1
passive-interface default
no passive-interface FastEthernet0/0.17
no passive-interface FastEthernet0/0.88
network 172.16.0.0
!        
router bgp 100
bgp log-neighbor-changes
neighbor 172.16.17.7 remote-as 700
neighbor 172.16.123.2 remote-as 64600
neighbor FE80::3333:3333 remote-as 64600
neighbor FE80::3333:3333 ebgp-multihop 255
neighbor FE80::3333:3333 update-source Serial1/0.123
!
address-family ipv4
neighbor 172.16.17.7 activate
neighbor 172.16.17.7 remove-private-as
neighbor 172.16.123.2 activate
neighbor FE80::3333:3333 activate
no auto-summary
no synchronization
aggregate-address 192.168.100.0 255.255.252.0 as-set summary-only
exit-address-family
!
address-family ipv6
neighbor FE80::3333:3333 activate
neighbor FE80::3333:3333 route-map NH out
network FEC0::1111:0/125
redistribute connected
redistribute ospf 1 match internal external 1 external 2
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
ip prefix-list RIP_TO_OSPF seq 5 permit 172.16.80.0/27
ip prefix-list RIP_TO_OSPF seq 10 permit 172.16.77.0/24
ip prefix-list RIP_TO_OSPF seq 15 permit 172.16.17.0/24
ip prefix-list RIP_TO_OSPF seq 20 permit 172.16.88.0/24
ip prefix-list RIP_TO_OSPF seq 25 permit 172.16.10.0/24
ip prefix-list RIP_TO_OSPF seq 30 permit 172.16.14.0/24
access-list 101 permit udp host 10.1.1.1 host 10.1.1.128 eq 5128
ipv6 router ospf 1
log-adjacency-changes
redistribute connected
redistribute bgp 100
!
!        
route-map NH permit 10
set ipv6 next-hop FEC0::BBBB:1
!
route-map RIP_TO_OSPF permit 10
match ip address prefix-list RIP_TO_OSPF
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
alias exec srb sh run | b
alias exec sri sh run | i
alias exec ship sh ip int brief
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
!
ntp master 5
!
end
 
R1#
 
 
 

 
Router R2:
 
R2#sh run
Building configuration...
 
Current configuration : 3198 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip rcmd rsh-enable
ip rcmd remote-host R1 172.16.10.1 R1 enable
ip tcp synwait-time 5
!
!        
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
!
!
!
interface Tunnel203
ip unnumbered Serial1/1
ip pim dense-mode
tunnel source 172.16.20.5
tunnel destination 172.16.30.3
!
interface Loopback2
ip address 172.16.2.1 255.255.255.0
!
interface Loopback20
ip address 172.16.20.5 255.255.255.252
ip pim dense-mode
ip ospf network point-to-point
ip igmp join-group 230.30.30.30
!
interface Loopback222
ip address 2.2.2.2 255.255.255.0
!
interface Serial1/0
ip address 172.16.123.2 255.255.255.0
ip pim dense-mode
encapsulation frame-relay
ip ospf network broadcast
ip ospf priority 0
ipv6 address FEC0::BBBB:2/120
ipv6 address FE80::2222:2222 link-local
ipv6 ospf priority 0
ipv6 ospf 1 area 0
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
frame-relay map ipv6 FE80::1111:1111 201 broadcast
frame-relay map ipv6 FE80::3333:3333 201
frame-relay map ipv6 FEC0::BBBB:1 201
frame-relay map ipv6 FEC0::BBBB:3 201
frame-relay map ip 172.16.123.1 201 broadcast
frame-relay map ip 172.16.123.2 201
frame-relay map ip 172.16.123.3 201
frame-relay interface-dlci 201
no frame-relay inverse-arp
frame-relay lmi-type cisco
!        
interface Serial1/1
ip address 172.16.25.2 255.255.255.0
ip pim dense-mode
ipv6 address FEC0::AAAA:2/120
ipv6 address FE80::2525:2222 link-local
ipv6 rip SAMPLE enable
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router ospf 100
log-adjacency-changes
area 20 range 172.16.20.0 255.255.255.0
area 25 virtual-link 172.16.50.1
redistribute connected subnets route-map C_TO_OSPF
redistribute bgp 64600 subnets
passive-interface Tunnel203
network 172.16.20.4 0.0.0.3 area 20
network 172.16.25.0 0.0.0.255 area 25
network 172.16.123.0 0.0.0.255 area 0
default-information originate always
!
router bgp 64600
synchronization
bgp log-neighbor-changes
neighbor 172.16.123.1 remote-as 100
neighbor 172.16.123.3 remote-as 64600
no auto-summary
!
ip http server
no ip http secure-server
!
!
!
access-list 10 permit 172.16.2.0 0.0.0.255
ipv6 router ospf 1
log-adjacency-changes
redistribute connected
redistribute rip SAMPLE
!
ipv6 router rip SAMPLE
redistribute connected metric 1
redistribute ospf 1 metric 1
!
!
route-map C_TO_OSPF permit 10
match ip address 10
!
!
!
control-plane
!
!
!
!
!
!
!        
!
!
alias exec srb sh run | b
alias exec sri sh run | i
alias exec ship sh ip int brief
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
!
!
end
         
R2#
 
 
 

 
Router R3:
 
 
R3#show run
Building configuration...
 
Current configuration : 4043 bytes
!
! No configuration change since last restart
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip rcmd rsh-enable
ip rcmd remote-host R1 172.16.10.1 R1 enable
ip tcp synwait-time 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
!
!
!
!
!
interface Tunnel302
ip unnumbered Serial1/0
ip pim dense-mode
tunnel source 172.16.30.3
tunnel destination 172.16.20.5
!
interface Loopback30
ip address 172.16.30.3 255.255.252.0
ip pim dense-mode
ip ospf network point-to-point
ip igmp join-group 230.30.30.30
!
interface Loopback333
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 172.16.36.3 255.255.255.0
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
ipv6 address FEC0::D3D3:3/120
ipv6 address FE80::D3D3:3333 link-local
ipv6 rip SAMPLE enable
standby 1 ip 172.16.36.1
standby 1 priority 110
standby 1 preempt
!
interface Serial1/0
ip address 172.16.123.3 255.255.255.0
ip pim dense-mode
encapsulation frame-relay
ip ospf network broadcast
ip ospf priority 0
ipv6 address FEC0::BBBB:3/120
ipv6 address FE80::3333:3333 link-local
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
frame-relay map ipv6 FE80::1111:1111 301 broadcast
frame-relay map ipv6 FE80::2222:2222 301
frame-relay map ipv6 FEC0::BBBB:1 301
frame-relay map ipv6 FEC0::BBBB:2 301
frame-relay map ip 172.16.123.1 301 broadcast
frame-relay map ip 172.16.123.2 301
frame-relay map ip 172.16.123.3 301
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router eigrp 1
redistribute ospf 100 metric 1500 100 255 1 1500
passive-interface default
no passive-interface FastEthernet0/0
network 172.16.36.0 0.0.0.255
distribute-list 10 out FastEthernet0/0
no auto-summary
no eigrp log-neighbor-changes
!
router ospf 100
log-adjacency-changes
area 30 range 3.0.0.0 255.0.0.0
redistribute eigrp 1 metric 20 subnets
passive-interface Tunnel302
network 3.3.3.0 0.0.0.255 area 30
network 172.16.28.0 0.0.3.255 area 30
network 172.16.123.0 0.0.0.255 area 0
!        
router bgp 64600
bgp log-neighbor-changes
neighbor 172.16.36.6 remote-as 64600
neighbor 172.16.123.2 remote-as 64600
neighbor FE80::1111:1111 remote-as 100
neighbor FE80::1111:1111 ebgp-multihop 255
neighbor FE80::1111:1111 update-source Serial1/0
!
address-family ipv4
neighbor 172.16.36.6 activate
neighbor 172.16.36.6 route-reflector-client
neighbor 172.16.123.2 activate
neighbor 172.16.123.2 route-reflector-client
no neighbor FE80::1111:1111 activate
no auto-summary
synchronization
network 3.0.0.0
exit-address-family
!
address-family ipv6
neighbor FE80::1111:1111 activate
neighbor FE80::1111:1111 route-map NH out
redistribute connected
redistribute rip SAMPLE
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
!
!
ip mroute 172.16.25.5 255.255.255.255 Tunnel302
!
access-list 10 permit 0.0.0.0
access-list 10 deny   any
ipv6 router rip SAMPLE
redistribute connected metric 1
redistribute bgp 64600 metric 1
!
!
route-map NH permit 10
set ipv6 next-hop FEC0::BBBB:3
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
alias exec srb sh run | b
alias exec sri sh run | i
alias exec ship sh ip int brief
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
!
ntp clock-period 17180061
ntp server 172.16.123.1
!
end
 
R3#

 
Router R4:
 
R4#show run
Building configuration...
 
Current configuration : 1564 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip rcmd rsh-enable
ip rcmd remote-host R1 172.16.10.1 R1 enable
ip tcp synwait-time 5
!
!        
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin privilege 15 password 0 adminnmc
!
!
!        
!
!
!
interface Loopback40
ip address 172.16.40.1 255.255.255.128
!
interface Serial1/0
ip address 172.16.14.4 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
cdp enable
frame-relay map ip 172.16.14.1 401 broadcast
frame-relay map ip 172.16.14.4 401
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!        
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
ip http server
ip http port 8090
ip http access-class 36
ip http authentication local
no ip http secure-server
ip http max-connections 2
!
!
!
access-list 36 permit 172.16.36.0 0.0.0.255
!        
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
!
!
end
 
R4#
 
 
 

 
Router R5:
 
R5#sh run
Building configuration...
 
Current configuration : 1913 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip rcmd rsh-enable
ip rcmd remote-host R1 172.16.10.1 R1 enable
ip tcp synwait-time 5
!        
!
ip cef
no ip domain lookup
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
  logging enable
  logging size 300
  hidekeys
!
!
!
!
!
!
interface Loopback50
ip address 172.16.50.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback500
no ip address
ipv6 address FEC0::5555:1/125
ipv6 rip RIPIPV6 enable
!
interface Serial1/0
ip address 172.16.25.5 255.255.255.0
ipv6 address FEC0::AAAA:5/120
ipv6 address FE80::2525:5555 link-local
ipv6 rip SAMPLE enable
serial restart-delay 0
clock rate 64000
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!        
router ospf 100
log-adjacency-changes
area 25 virtual-link 172.16.20.5
network 172.16.25.0 0.0.0.255 area 25
network 172.16.50.0 0.0.0.255 area 50
!
ip http server
no ip http secure-server
!
!
!
ipv6 router rip RIPIPV6
!
ipv6 router rip SAMPLE
redistribute connected metric 1
redistribute rip RIPIPV6 metric 1
!
!
!
!
control-plane
!
!        
!
!
!
!
!
!
!
alias exec srb sh run | b
alias exec sri sh run | i
alias exec ship sh ip int brief
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
!
!
end
 
R5#

 
Router R6:
 
R6#sh run
Building configuration...
 
Current configuration : 2319 bytes
!
! NVRAM config last updated at 00:05:31 UTC Fri Mar 1 2002
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip rcmd rsh-enable
ip rcmd remote-host R1 172.16.10.1 R1 enable
ip tcp synwait-time 5
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.36.1 172.16.36.10
!
ip dhcp pool nmc
   network 172.16.36.0 255.255.255.0
   default-router 172.16.36.1
   dns-server 10.10.10.10
   domain-name nmc.net
!
ip dhcp pool 1
   host 172.16.36.61 255.255.255.0
   hardware-address 0050.04df.5f61
   default-router 172.16.36.1
   dns-server 10.10.10.10
   domain-name nmc.net
!
ip dhcp pool 2
   host 172.16.36.60 255.255.255.0
   hardware-address 0050.04df.5f60
   dns-server 10.10.10.10
   domain-name nmc.net
   default-router 172.16.36.1
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
!
!
!
interface Loopback60
ip address 172.16.60.1 255.255.255.0
!
interface Loopback600
no ip address
ipv6 address FEC0::6666:1/125
!
interface FastEthernet0/0
ip address 172.16.36.6 255.255.255.0
duplex auto
speed auto
ipv6 address FEC0::D3D3:6/120
ipv6 address FE80::D3D3:6666 link-local
ipv6 rip SAMPLE enable
standby 1 ip 172.16.36.1
standby 1 preempt
!
router eigrp 1
redistribute connected route-map C_TO_EIGRP
redistribute eigrp 2
network 172.16.36.0 0.0.0.255
default-metric 1000 100 255 3 1500
auto-summary
!
router eigrp 2
redistribute eigrp 1
network 172.16.36.0 0.0.0.255
default-metric 1000 100 255 3 1500
auto-summary
!
router bgp 64600
no synchronization
bgp log-neighbor-changes
neighbor 172.16.36.3 remote-as 64600
no auto-summary
!
ip http server
no ip http secure-server
!
!
!
access-list 10 permit 172.16.60.0 0.0.0.255
ipv6 router rip SAMPLE
redistribute connected metric 1
!
!
route-map C_TO_EIGRP permit 10
match ip address 10
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
!
ntp clock-period 17179774
ntp peer 172.16.36.3
!
end
 
R6#

 
Router FRS:
 
FRS#show run
Building configuration...
 
Current configuration : 2874 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip rcmd rsh-enable
ip rcmd remote-host R1 172.16.10.1 R1 enable
ip tcp synwait-time 5
!
!        
ip cef
no ip domain lookup
!
!
!
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
!
!
interface Loopback71
ip address 172.16.77.7 255.255.255.0
!
interface Loopback19100
ip address 192.168.100.1 255.255.255.0
!
interface Loopback19101
ip address 192.168.101.1 255.255.255.0
!
interface Loopback19102
ip address 192.168.102.1 255.255.255.0
!
interface Loopback19103
ip address 192.168.103.1 255.255.255.0
!
interface Loopback19104
ip address 192.168.104.1 255.255.255.0
!
interface Loopback19105
ip address 192.168.105.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.17.7 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
frame-relay intf-type dce
frame-relay route 102 interface Serial1/1 201
frame-relay route 103 interface Serial1/2 301
frame-relay route 104 interface Serial1/3 401
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay intf-type dce
frame-relay route 201 interface Serial1/0 102
frame-relay route 203 interface Serial1/2 302
frame-relay route 204 interface Serial1/3 402
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay intf-type dce
frame-relay route 301 interface Serial1/0 103
frame-relay route 302 interface Serial1/1 203
frame-relay route 304 interface Serial1/3 403
!
interface Serial1/3
no ip address
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay intf-type dce
frame-relay route 401 interface Serial1/0 104
frame-relay route 402 interface Serial1/1 204
frame-relay route 403 interface Serial1/2 304
!
router rip
version 2
passive-interface default
no passive-interface FastEthernet0/0
network 172.16.0.0
!
router bgp 700
no synchronization
bgp log-neighbor-changes
redistribute connected route-map C_TO_BGP
neighbor 172.16.17.1 remote-as 100
no auto-summary
!
no ip http server
no ip http secure-server
!
!
!
access-list 10 permit 192.168.100.0 0.0.3.255
access-list 10 permit 192.168.104.0 0.0.1.255
no cdp run
!        
route-map C_TO_BGP permit 10
match ip address 10
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
!
!
end
 
FRS#

Router CAT1:
 
CAT1#show run
Building configuration...
 
Current configuration : 984 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CAT1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip tcp synwait-time 5
!
!
ip cef   
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
interface Loopback80
ip address 172.16.80.1 255.255.255.224
!
interface FastEthernet0/0
ip address 172.16.88.2 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
passive-interface default
no passive-interface FastEthernet0/0
network 172.16.0.0
!
no ip http server
no ip http secure-server
!
!
!
!
!
!        
control-plane
!
!
!
!
!
!
!
!
!
alias exec srb sh run | b
alias exec sri sh run | i
alias exec ship sh ip int brief
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
line vty 5 15
login
!
!
end
 
CAT1#

 
Router CAT2:
 
CAT2#sho run
Building configuration...
 
Current configuration : 1104 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CAT2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip tcp synwait-time 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
interface Loopback120
ip address 172.16.120.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.36.20 255.255.255.0
ip summary-address eigrp 2 172.16.120.0 255.255.254.0 5
duplex auto
speed auto
!
router eigrp 2
passive-interface default
no passive-interface FastEthernet0/0
network 172.16.36.0 0.0.0.255
network 172.16.120.0 0.0.0.255
no auto-summary
no eigrp log-neighbor-changes
!
ip http server
no ip http secure-server
!
!
!
!        
!
!
control-plane
!
!
!
!
!
!
!
!
!
alias exec srb sh run | b
alias exec sri sh run | i
alias exec ship sh ip int brief
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
line vty 5 15
login
!
!
end
 
CAT2#

Appendix B.
 
Network file for the DOiT Scenario 1.
 
[localhost]
workingdir = /home/study/
autostart = true
 
 
[[3640]]
idlepc = 0x606100e8
image = /home/study/c3640-jk9o3s-mz.124-5-uncompressed.bin
ram = 128
 
[[ROUTER FRS]]
console = 2007
model = 3640
s1/0 = R1 s1/0
s1/1 = R2 s1/0
s1/2 = R3 s1/0
s1/3 = R4 s1/0
F0/0 = SW1 7
[[ROUTER R1]]
console = 2001
model = 3640
F0/0 = SW1 1
#
[[ROUTER R2]]
console = 2002
model = 3640
F0/0 = SW1 2
#
[[ROUTER R3]]
console = 2003
model = 3640
F0/0 = SW1 3
F2/0 = SW1 13
#
[[ROUTER R4]]
console = 2004
model = 3640
F0/0 = SW1 4
#
[[ROUTER R5]]
console = 2005
model = 3640
F0/0 = SW1 5
#
[[ROUTER R6]]
console = 2006
model = 3640
F0/0 = SW1 6
#
[localhost:7201]
udp = 11000
#
[[3640]]
idlepc = 0x606100e8
image = /home/study/c3640-jk9o3s-mz.124-5-uncompressed.bin
ram = 128
#
[[ROUTER CAT1]]
console = 2008
model = 3640
ram = 128
F0/0 = SW1 8
#
[[ROUTER CAT2]]
console = 2009
model = 3640
ram = 128
F0/0 = SW1 9
#
[[ETHSW SW1]]
1 = access 40
2 = access 10
3 = access 20
13 = access 30
4 = access 30
5 = access 20
6 = dot1q
7 = access 3000
8 = access 30
9 = access 10

Posted by 불량소금
,